p:: CLI

The fastest way to clone an SD card on macOS

Identify your sd card

diskutil list

Copy the SD card as a disk image (dmg)

sudo gdd if=/dev/rdisk2 of=sd_backup.dmg status=progress bs=16M

Copy the disk image (dmg) to your SD card

{
    sudo diskutil unmountDisk /dev/disk2
    sudo gdd of=/dev/rdisk2 if=sd_backup.dmg status=progress bs=16M
}